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You likely spend a lot of time in your IDE. Any time you can save while using it is a good thing. 

In this guide, you'll learn a few tips on how to save time using SQL Server Management Studio. 

Here's the summary: 

● Use Alt + Shift + click, or Alt + Shift + Up/Down to select text on multiple lines. 
● Set colours for different environments so you can tell which environment you're in. 
● Press Ctrl + R to hide the results to see more of your query. 
● Comment code with Ctrl + K, Ctrl + C, and uncomment code with Ctrl + K, Ctrl + U. 
● Use the Object Explorer Details window to get a row count of all tables without running a 

script. 
● Use bookmarks in your code to navigate within large scripts. 
● Enable line numbers to easily navigate within your script. 
● Use the Code Snippets feature to insert commonly-used SQL code. 
● Change the case of parts of your code by using Ctrl + Shift + U for Uppercase or Ctrl + Shift + L 

for Lowercase. 
● Use other editing shortcuts shown in Edit > Advanced. 
● Include recent database changes in Intellisense by refreshing the cache with Ctrl + Shift + R. 
● Create tab groups to allow you to view two queries side-by-side. 
● Assign keyboard shortcuts to any menu item to save time where shortcuts don't exist. 

Let's get into the details. 

 

Use Alt to Select Multiple Lines 

One of the best tips for working with queries in SSMS is to be able to work with multiple lines at once. 

This is a common feature in many text editors and works in SSMS as well. 

It will allow you to: 

● select text on multiple lines, which you can then copy or delete 
● add a cursor to multiple lines, allowing you to type table aliases or commas once and have it 

appear on every line 

To do this in SSMS, hold Alt and Shift, and press Up or Down. A new cursor will be added (the red and 
green cursors in the image below): 

 

 
www.DatabaseStar.com  1



 

Timesaver Guide: SQL Server Management Studio 

 

 

You can hold Alt and Shift and press Left or Right to highlight the text on each of these lines if you like. 

 

You can also add a lot of cursors by placing the cursor at the bottom, scrolling to the top of where you 
want the cursor to go, press Alt and Shift, and click where you want the cursor to go. You'll get multiple 
cursors without having to use Up or Down a lot. 

 

Use Colours for Different Environments 

If you work in different environments (e.g. Local, Dev, Test, Prod), it can get confusing to know which 
one your current window is connected to. 

Fortunately, there's a tip you can use to help you. 

SSMS allows you to colour-code each of your connections. This means you can assign different colours 
to each connection, and the colour you select will appear in the status bar at the bottom of the screen. 

If you assign the colour Red to your Production connections, for example you'll see that when you're 
writing code your status bar is Red, indicating that you should be more careful as you're on 
Production. You could assign Green, for example, to Local, which is an environment you have more 
freedom with. 

 

To set a colour for a connection, it needs to be a Registered Server. You can register a connection by 
right clicking on it and selecting Register. 

Once it is registered, open the Registered Servers view by clicking View > Registered Servers. 
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Open the properties for a server by right clicking on it and selecting Properties. 

 

Go to the Connection Properties panel. 

Select "Use custom colour", and click the Select button. 
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Select a colour to use and click OK. 

Click Save. 

Now, at the bottom of your query editor, the status bar will be shown in the colour you selected. 

 

This is a good way to see which database you're on. 

 

Hide the Results So You Can See All Of Your Code 

When you run a SELECT query, the results appear at the bottom of the screen in a new tab. 

It can take up quite a bit of space, which can make it hard to work with your code. 

You can quickly toggle the results panel on and off by pressing Ctrl + R. This will give you more room to 
work with your code. 
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Comment and Uncomment Shortcuts 

If you ever need to comment and uncomment your code, you can do that quickly with the keyboard. 

To comment a line of code, press Ctrl + K, then Ctrl + C. This will add commenting characters to your 
line: 

 

To uncomment a line of code, press Ctrl + K, then Ctrl + U. This will remove the comments: 

 

It's a bit quicker than adding them manually or using the menus. 

 

Get Row Count Without Running a Script 

Sometimes you want to get the count of rows in one or many tables. One way to do it is to run a script 
to SELECT COUNT(*) from these tables. 

However, a faster way to do this is to use a feature in SSMS. Go to View > Object Explorer Details. A 
window will appear that shows a list of objects. 
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Open Databases, then open the database you want to see. Then open Tables. 

 

Right click on the column headers and select Row Count to show the row count column. 

 

You can then see a column in this list called Row Count that shows the number of rows in each table. 
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This can be a big time saver if you're looking for the row count. 

 

Use Bookmarks In Your Code 

If you work with a long SQL script, you'll find yourself moving up and down the script a lot. 

A feature in SSMS that can help you with this is Bookmarks. 

You can set a bookmark at a line of code, and then use a keyboard shortcut to quickly navigate to it. 

You can see all of the bookmark features in Edit > Bookmarks. 
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To set a bookmark, press Ctrl + K, Ctrl + K. 

An icon will appear in the sidebar that represents the bookmark. 

 

With multiple bookmarks, you can navigate between them with the keyboard: 

● Next Bookmark: Ctrl + K, Ctrl + N 
● Previous Bookmark: Ctrl + K, Ctrl + P. 

More bookmark commands are available in the menu. 
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Show Line Numbers 

Line numbers in your SQL code can help you navigate to the right spot when you get an error in your 
code. These are often enabled by default, but if they are not, you can enable them. 

To enable line numbers, go to Tools > Options. 

 

In the Options window, navigate to Text Editor > All Languages > General. 

Or, you can search for "line numbers" in the search box. 
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Check the box labelled "Line numbers" 

Line numbers are now displayed in your SQL editor windows. 

 

 

Use Code Snippets 

When working with SQL, there are often some SQL commands and scripts that you use a lot. 

One way to work with them is to save them all in a folder. But then you would have to open them all 
individually to use them. 

A faster way is to use an SSMS feature called Code Snippets. This feature lets you store queries as 
saved items in SSMS, and then access them easily from within the application. 

To view the code snippets, you can either; 

● Go to Edit > Intellisense > Insert Snippet 
● Right click in the editor and select Insert Snippet 
● Press Ctrl + K, Ctrl + X. 
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You'll then be shown a list of built-in snippets to use, such as creating a table. 

 

You can create your own snippets as well, so you can use them in SSMS. This is a good way to save time 
when working with SQL frequently. 

 

Quickly Change Case 

If you are typing code, or copying code from another location, it might not be in the case you want. 
Perhaps you prefer upper case and the code is in lower case. Or vice versa. 

Rather than typing out the code again, you can easily change the case of existing code. 

To do this, select the words or code you want to convert. 

Change the case by either: 

● Ctrl + Shift + U for Upper Case 
● Ctrl + Shift + L for Lower Case 

For example, here's the code before changing to lower case: 

 

Here it is in lower case. 
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You can change individual words as well. All you need to do is select them and use the shortcuts. 

 

Use Other Editing Shortcuts 

There are many other ways of editing your SQL code that can be done with shortcuts. 

You can see many of them in the Edit > Advanced menu. 

 

Many of them have keyboard shortcuts as well. It's helpful to remember these. 

Some of the more useful ones are: 
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● Move selected lines up or down: an easy way to rearrange columns in the SELECT clause or 
WHERE clause. 

● Comment and uncomment selection: easily add or remove comments (as we saw earlier) 

Have a look at each of the items in this menu to see if they will be useful for you. 

 

Refresh Local Cache for Intellisense 

The autocomplete, or intellisense feature, in SSMS allows you to select table and column names from a 
dropdown list as you're writing code, making it faster to complete your SQL queries. 

However, when you create new tables or make other changes to your database, the changes often 
don't appear in the intellisense list. 

This is because the names are cached, and if you make changes to the database, the cache is not 
immediately updated. 

You can trigger this update, which is a good thing to do after you make changes to your database. 

To trigger the cache update, go to Edit > Intellisense > Refresh Local Cache. 

 

Or you can press Ctrl + Shift + R, which is much faster. 
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Create Tab Groups to View Multiple Files at Once 

Have you ever wanted or needed to work on two SQL queries at once? You can do that in SSMS by 
using a feature called Tab Groups. 

First, open two queries in SSMS. These will appear in two different tabs. 

 

Then, right click on one of the tab headings and select either New Horizontal Tab Group or New 
Vertical Tab Group. 

 

What's the difference? 

● Horizontal tab group: two tabs are on top of each other 
● Vertical tab group: two tabs are side by side. 

Here's what the horizontal tab group looks like: 
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Here's what the vertical tab group looks like: 

 

This can make it easier to work on two files at once. 

Personally I prefer the Vertical Tab Group. 

To undo the tab groups, right click on either tab and select Move to Previous Tab Group. 
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Assign Keyboard Shortcuts to Menu Items 

You might notice as you're looking through the menus in SSMS that there are some items that you use 
that don't have keyboard shortcuts. 

It would be great if they did have shortcuts! 

Fortunately, you can set them yourself in SSMS. 

To do this, right click on the toolbar and select Customise. 

 

Click on the Keyboard button. A new window is displayed. 
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Search for the command you want to add a shortcut for. In this example, I've selected 
"Edit.IncreaseLineIndent" which I understand is the Increase Line Indent command in the Edit 
Advanced menu. 

 

Click in the Press Shortcut Keys box and enter a new shortcut for this command. 

Click OK on the windows to save and close them. This shortcut can now be used to run this command. 
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Conclusion 

Thanks for taking the time to read this Timesaver guide on SQL Server Management Studio. I hope you 
learned a thing or two and can save some time when using SSSMS. 

Take a look at Database Star Academy for more time saving tips and other material on SQL 
development. 

Thanks, 

Ben Brumm 

www.DatabaseStar.com 
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